Dashboard is not responsive or slow, and intermittent login failures
Incident Report for Bird
Resolved
The root cause of the problem has been identified: the resource exhaustion of the queueing system behind our Billing API's has led to unavailability of Billing API (leading to degrading performance of the Dashboard web interfaces).

Our team is going to take necessary actions that prevent this outage from happening in the future.
Posted Jan 13, 2022 - 19:13 CET
Monitoring
Since 15:59 CET, we're observing the recovery of service. Now the Dashboard is operational.
We're investigating the root cause, and actively monitoring the situation.

We'll provide the next update once the root cause is identified.
Posted Jan 13, 2022 - 16:06 CET
Investigating
Since 15:25 CET, we're observing an increasing volume of errors related to Dashboard, leading to login failures and the overall dashboard experience (increase in page load time).

We're investigating the cause.
Posted Jan 13, 2022 - 15:25 CET
This incident affected: Connectivity Platform (Dashboard - dashboard.messagebird.com).