USA intermittent delays on delivery/DLRs
Incident Report for MessageBird
Resolved
This incident has been resolved.
Posted Nov 20, 2021 - 03:51 CET
Investigating
We are currently experiencing degraded delivery performance to US Cellular, USA (MCCMNC: 311580), and this may result in delayed message delivery to this network. We are working with our operator partner to resolve the issue, and we will update this status once we have verified resolution.
Posted Nov 19, 2021 - 17:19 CET
This incident affected: Connectivity (SMS - Northern America).