Unable to Display Product Catalogs
Incident Report for Bird
Resolved
A fix has been deployed for this issue. Product Catalogs can now be displayed.
Posted Apr 19, 2024 - 19:20 CEST
Identified
We have identified the cause of this issue and we are preparing a fix.
Posted Apr 19, 2024 - 19:03 CEST
Investigating
We are investigating an issue with unable to retrieve Product Catalogs.
Posted Apr 19, 2024 - 18:53 CEST
This incident affected: Site - bird.com.