Inbox degraded service
Incident Report for MessageBird
Resolved
This incident has been resolved.
Posted Aug 19, 2020 - 19:03 CEST
Update
We are continuing to investigate this issue.
Posted Aug 19, 2020 - 19:03 CEST
Investigating
We are currently experiencing degraded service in Inbox, with some customers unable to load Tickets or seeing unexpected errors
Posted Aug 19, 2020 - 18:33 CEST
This incident affected: Inbox.