Issue displaying contact interactions in Inbox
Incident Report for MessageBird
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 11:16 CEST
Monitoring
We have mitigated the issue and will continue to monitor the situation closely.
Posted Oct 14, 2020 - 11:09 CEST
Investigating
We are investigating problems displaying contact interactions in Inbox.
Posted Oct 14, 2020 - 11:00 CEST
This incident affected: Inbox.