SMS Delivery Failures to United States & Canada for 10DLC senders
Incident Report for Bird
Resolved
This incident has been resolved.
Posted May 12, 2022 - 17:00 CEST
Monitoring
The situation has been mitigated. We're observing the results.
Posted May 12, 2022 - 15:32 CEST
Update
We are continuing to investigate this issue.
Posted May 12, 2022 - 15:03 CEST
Update
We are continuing to investigate this issue.
Posted May 12, 2022 - 12:37 CEST
Investigating
We're currently investigating an issue causing SMS delivery failures to the United States & Canada, for messages sent from a 10DLC long number.

Messages sent from Toll-Free Numbers and Short Codes are delivered as expected.
Posted May 12, 2022 - 11:50 CEST
This incident affected: Connectivity Platform (SMS - Connectivity - NORAM).