Inbox settings are suffering from degraded performance
Incident Report for MessageBird
Resolved
This incident has been resolved.
Posted Aug 26, 2020 - 09:29 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2020 - 08:39 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 26, 2020 - 08:26 CEST
Investigating
We are currently investigating reports of degraded performance of the Inbox settings pages.
Posted Aug 26, 2020 - 07:47 CEST
This incident affected: Inbox.